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제품 소개 
InterCAD™ COWORK 이란? 

 OrCAD Capture로 작업한 회로도를 이용하여 PADS Layout에 바로 적용할 수 있는 프로그램이다. 
 

Netlist를 OrCAD로부터 출력하여 사용자가 수정하는 방법은 많은 휴먼에러를 발생하였고 개발 중 발생한 회로변경 또

한 사용자가 직접 Netlist를 수정해야 하므로 회로도와 Layout 데이터가 일치하지 않는 문제를 가지고 있었다. 
 

위 문제를 개선하기 위하여 OrCAD Netlist를 이용하여 ECO가 가능한 Interface 프로그램을 개발하였다, OrCAD 회로도

를 이용한 작업 시 발생할 수 있는 에러요소를 검증하는 기능과 OrCAD 회로 데이터를 Layout에 반영할 수 있는 
ECO 기능을 제공한다. 

 

OrCAD 

PADS Layout 

Back Annotate 
SWP File 생성 CoWork

 

Netlist  

데이터 출력 

Back Annotate / Cross Probing 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

표준 작업 디렉토리 구조 
 

모델명 모델.pcb 

     capture 

모델.cwk (cowor

모델.log (cowork

 
 
 
 
 
 
 
 
 

Note: 프로그램 사용시 필수사항은 아니지

      구조에 맞게 사용 하는 것이 바람직
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OrCAD files(*.dsn/*.obj) 

만 OrCAD를 이용한 설계시 표준디렉토리 
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OrCAD Capture 
PADS Netlist 생성 

1 OrCAD Capture Tools > Create Netlist를 실행하거나 표기된 아이콘을 선택하면 Netlist 생성 화면이 나타난다. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

2 위 화면에서 Other를 선택한 후 Formatters에서 padspcb.dll을 선택하고 확인을 누르면 해당 모델에 asc 파일이 
생성된다. 

 
3 회로도에 error가 있는 경우 아래와 같은 메시지 박스가 출력되며 데이터가 생성되지 않는다. 이 경우 Session 

log창에서 error를 확인한 후 error를 해결하고 다시 실행한다. 
 
 
 
 
 
 
 
 
 
 
 
 

 Important:  Netlist 만들기 전에 전체 회로도에 사용한 부품 Property에 서로 다른 Reference가  
중복으로 입력 되었는지 반드시 확인해야 한다. 

만약 서로 다른 Reference가 중복으로 입력되어 있으면 Back Annotate 및 Cross Probing이 잘못 되며 
Layout의 부품 배치정보가 변경 될 수 있다. 
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 확인방법 

a. OrCAD  회로도를 오픈 한다. 
b. 

 
 

Property Editor창의 리스트 중 Reference가 다르게 중복된  행으로 표시된다. 
     행이 있으면 중복된 Reference를 제거해야 한다. 

 

 

 
 

dsn을 선택한 후 마우스 오른쪽 버튼을 이용하여 Edit Object Properties를 실행한다. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

c.  경우 노란색

리스트 전체를 확인하고 만약 노란색
 

중복된 Reference가 있는 회로도  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
정상적인 회로도  
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 해결방법 
a. Property Editor창의 왼쪽 모서리를 클릭하여 전체 Property를 선택한다. 
b. 

 
 Reference를 제거한 OrCAD 데이터를 제공하여 반복작업을 

       하지 않도록 한다. 

 

     있다. 
Note:  cowork 프로그램 사용 중 주의사항이 발견되면 경고/오류 메시지가 출력된다. 

1  사용하지 않는다. 

 REF: 숫자 및 영자를 제외한 모든 문자 

2 동일한 Value에 서로 다른 Pin수의 Part를 사용할 수 없다. 

 

 때문에 동일한 Value를 사용한 
      부품 중 Pin수가 다른 부품이 없도록 회로도를 작성해야 한다. 

3 다, 사용자가 임의로 만들어 
Reference만 동일하게 변경 할 경우 Layout에서 서로 다른 부품으로 인식된다. 

4 
Number가 알파벳(Anode, Cathode, Emitter, 

Base…)로 표기되어 있는데 Number로 수정해서 사용해야 한다. 

 

Delete Property 버튼을 클릭하여 중복 Reference가 제거한다. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Note: 회로 설계자에게 중복

b 

a 

회로도 작성시 주의 사항 
OrCAD 데이터를 PADS Layout에 사용하기 위해서 회로도 작성시 주의해야 할 항목이

부품 Value 및 Reference에 특수문자는

 부품 Value: 한글 및 특수문자 

OrCAD 회로도에서 
 
 
 
 
 
 
 
 

Note: cowork은 OrCAD Value를 기준으로 Part(Decal)를 Mapping 하기

10K  
3Pin 

10K  
2Pin 

회로도에 Multi-Symbol(Gate..)을 사용할 때 Multi Package로 만들어 사용 해야 된

BGA외 Pin Number가 알파벳으로 이루어진 부품은 사용할 수 없다. 
OrCAD에서 기본으로 제공하는 라이브러리 중 TR, Diode, FET는 Pin 
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COWORK 
프로그램 실행 
바탕화면 cowork아이콘 또는 시작 > 프로그램 > interCAD > cowork을 이용하여 아래와 같이 프로그램을 실행한다. 

Note: cowork 프로그램은 실행중인 PADS Layout에 종속되어 실행되는 프로그램으로 PADS Layout이. 
실행되지 않았을 경우 에러 메시지가 출력되고 프로그램이 종료된다. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 PADS Layout이 실행되지 않았을 때 출력되는 에러 메시지 
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OrCAD File Open 및 Catalog 생성 
OrCAD에서 생성한 Netlist 파일을 이용하여 Catalog를 생성하거나 최신 정보로 업데이트 하는 기능이다. 

 

1 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

1 cowork에서 오픈 아이콘을 실행한다. 
Note:  PADS Layout이  “제목없음” 상태일 경우 파일 오픈 명령이 실행되지 않고 오류 메시지 박스가 

출력된다. 
신규 모델인 경우 매뉴얼 표준 작업 디렉토리 구조(3쪽)를 참조하여 현재 데이터를 저장하고 기존 모델

인 경우 사용할 데이터를 오픈 한 후 다시 실행하면 된다. 
 

2 OrCAD에서 Netlist를 출력한 OrCAD *.DSN 파일을 선택한 후 열기를 클릭하면 데이터를 Import하면서Catalog가 
생성 되거나 업데이트 된다. 

3 오류/경고 메시지 

 Netlist 구성파일 일부를 찾을 수 없습니다. OrCAD Capture를 이용하여 PADS Netlist를 생성한 후 다시 시도 
하십시오. 

선택한 OrCAD dsn파일과 같은 디렉토리에 PADS Netlist가 존재하지 않았을 때 Error 메시지가 출력되고 
Import가 중지된다. 

OrCAD에서 해당 DSN파일을 이용하여 PADS Netlist를 생성 후 다시 시도 하면 된다. 
 

 Netlist 구성파일의 버전이 일치하지 않습니다. OrCAD Capture를 이용하여 PADS Netlist를 다시 생성 하십시
오. 

선택한 OrCAD dsn파일과 같은 디렉토리에 있는 PADS Netlist가 임의로 수정되었을 때 Error 메시지가 
출력되고 Import가 중지된다. 
OrCAD에서 출력한 Netlist는 사용자가 임의로 변경할 수 없으며 변경이 필요한 경우 OrCAD 회로도에서 
변경한 후 Netlist를 생성하여 사용해야 한다.  

 

 마지막 변경날짜보다 이전에 생성된 Netlist를 참조하고 있습니다. 계속하시겠습니까? 

선택한 OrCAD dsn파일의 변경 날짜보다 Netlist가 이전에 생성된 경우 확인 메시지가 출력된다. 
확인 후 계속 진행하면 된다.  
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 Part Value에 사용할 수 없는 문자가 포함되어 있습니다. 

OrCAD에서 사용한 Part Value중 PADS Layout에서 사용할 수 없는 문자가 포함된 경우 Error 메시지가 
출력되고 Import가 중지된다. 
메시지를 확인하여 해당 Part의 Value를 수정한 후 다시 Netlist를 생성하여 사용하면 된다. 

 

 Pin Number에 사용할 수 없는 문자가 포함되어 있습니다. 

OrCAD에서 사용한 Part의 Pin Number중 PADS Layout에서 사용할 수 없는 문자가 포함된 경우 Error 
메시지가 출력되고 Import가 중지된다. 
메시지를 확인하여 해당 Part의 Pin Number를 수정한 후 다시 Netlist를 생성하여 사용하면 된다. 

 

 Part Value를 같이 사용한 부품 중 Pin수가 다른 부품이 있습니다. 

OrCAD에서 동일한 Value를 사용한 부품 중 Pin수가 다른 부품이 발견된 경우 Error 메시지가 출력되고 
Import가 중지된다. 

 
 
 

동일한 Value에 서로 다른 Pin수의 Part를 사용할 수 없다. 메시지를 확인하여 동일한 Value중 하나를 다른 
이름으로 변경한 후 다시 Netlist를 생성하여 사용하면 된다.  

 

10K 3Pin10K 2Pin 

 Net에 사용할 수 없는 문자가 포함되어 X??로 이름이 변경되었습니다. 

OrCAD에 사용한 Net명중 PADS Layout에서 사용할 수 없는 문자가 포함된 경우 Net명이 X+임의숫자로 
변경된다. 이 경우 Net명 변경 정보가 메시지 창에 표시되며 자세한 변경 정보는 OrCAD에서 Netlist 생성시 
발생한 Session Log 파일을 통해 확인 할 수 있다. 

 

 Port/Offpag를 사용하지 않아 다른 페이지와 연결되지 못한 Net가 발견되었습니다. 

OrCAD는 offpag나 port를 사용하지 않고 Net명만 기입하여 회로를 작성한 경우 다른 sheet와 연결 되지 
않는다. 이 경우 Net명으로만 기입된 Net가 메시지 창에 표시되며 자세한 정보는 cowork > Window > Session 
Log를 통해 확인 할 수 있다. 

 
 
 
 
 
 
 
 
 
 

Net명으로 기입된 Net가 다른 sheet와 연결 되지 않아도 되는지 확인해야 한다. 
 

 One Pin Nets이 발견되었습니다. 

One pin nets이 발견되었을 때 One pin list가 메시지 창에 표시되며 자세한 정보는 cowork > Window > 
Session Log를 통해 확인할 수 있다. 

 

U3
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 None Electrical Part(?)가 발견되었습니다. 

     회로도에 사용한 부품 중 전기적 속성을 가지지 않는 부품이 발견되었을 때 Error 메시지가     
생성되며 Import가 중지된다. 

OrCAD에서 해당 Reference의 Part를 확인 하여 오류를 해결 한 후 다시 Netlist를 생성하여 
     사용하면 된다. 

     Ex) Hierarchical Block 심볼 또는 Title Block 심볼이 Part로 인식 되었을 수 있다. 
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Catalog mapping 
Netlist Import 실행 후 생성되거나 추가된 Catalog List에 Part를 Mapping해야 한다. 
 
 
 
 
 
 
 
 
 
 

1 

< Catalog > 

Part  
콤보박스 

 
Catalog 리스트 중 Part mapping이 안되었을 때 STATUS에 “*E*”라고 표기되며 ECO가 불가능하기 때문에 에러로 
표기된 Value에 Parts를 Mapping해야 한다. 

1 Mapping할 부품을 PADS에서 cowork 프로그램의 Part 콤보박스로 불러 온다. 
PADS Library Manager나 PADS Layout에서 부품을 선택하면 선택한 부품이 cowork Part 콤보박스로 불러진다. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Library Manager에서 부품선택 Layout에서 부품선택 

선택한 부품이

콤보박스로  
불러진다. 
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2 Catalog에서 Mapping할 Value를 Mapping한다.  

a. Catalog에서 Mapping할 Value를 마우스로 더블 클릭하거나  Add Part을 클릭하면 Part 콤보박스에 
적용된 Part가 선택된 Value에 Mapping된다. 

b. 이미 Mapping된 Value의 Part를 Copy해서 다른 Value에 Paste할 수 있다. 
 복사할 Value를 선택한 후 Ctrl+C을 입력하면 Part가 복사되고 Mapping할 Value를 선택한 후 
 Ctrl+V를 입력하면 복사한 Part가 적용된다. 

Note: 이전에 변경한 Mapping 정보를 취소하고 싶은 경우 Ctrl+Z를 입력하면 취소되며 최대 5개까지 
      연속해서 취소가 가능하다.  

 
Restore Catalog 

다른 Design의 Mapping 정보를 이용한 Restore Catalog 
다른 Design에서 사용한 Mapping정보를 이용해서 Catalog의 Part Mapping을 Restore 할 수 있는 기능이다. 

1 cowork > File > Restore 하단에 From File을 실행한다. 

2 다른 Design에서 사용한 Catalog File(*.cwk)을 선택 한 후 열기를 클릭한다.  
 Note: cowork을 이용하여 작업한 모델인 경우 해당 모델의 작업파일(*.pcb)이 위치한 디렉토리에 
       Catalog File(*.cwk) 파일이 존재한다. 

3 Restore Catalog 창에서 Restore할 버전과 Option을 선택한 후 “OK” 버튼을 클릭하면 Catalog가 Restore 된다. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 Version 

 cwk파일의 Catalog는 3개의 버전으로 관리되며 번호가 높을수록 최근 데이터이다. 

 Options 

a. Keep Assigned Part/Decal: Mapping이 되지 않은 Value의 Part만 Restore 한다. 

b. Replace All: Mapping 여부와 상관없이 모든 Value의 Part를 Restore 한다.  

c. Ask Before Part/Decal Change: Replace All Option시 Value의 Part가 이미 존재할 경우 변경 여부 선택할 
수 있는 창이 생성된다. 
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PAD Layout에 열려있는 Design을 이용한 Restore Catalog 
현재 열려있는 Design을 이용해서 Catalog의 Part Mapping을 Restore 할 수 있는 기능이다. 

1 cowork > File > Restore 하단에 Layout@design name을 실행한다. 

2 Option을 선택한 후 “OK” 버튼을 클릭하면 Catalog가 Restore 된다. 
 
 
 
 
 
 
 
 
 
 
 

 Options 

a. Keep Assigned Part/Decal: Mapping이 되지 않은 Value의 Part만 Restore 한다. 

b. Replace All: Mapping 여부와 상관없이 모든 Value의 Part를 Restore 한다.  

c. Ask Before Part/Decal Change: Replace All Option시 Value의 Part가 이미 존재할 경우 변경 여부 선택할 
수 있는 창이 생성된다. 

 
OrCAD 회로도의 Foot Print 정보를 이용한 Restore Catalog 
OrCAD 회로도에 입력된 Foot Print 정보를 이용해서 Catalog의 Part Mapping을 Restore 할 수 있는 기능이다. 

1 cowork > File > Restore 하단에 From File을 실행한다. 

2 File Open창에서 파일 형식을 CoWork Netlist(*.CNL)로 변경한 후 OrCAD의 Netlist를 생성한 디렉토리로 
이동하여 *.cnl 파일을 선택 한 후 열기를 클릭한다.  

 Note:  cnl 파일은 cowork에서 OrCAD 파일을 오픈하면 Netlist를 생성한 디렉토리에 자동으로 생성된다. 

3 Restore Catalog 창에서 Restore Option을 선택한 후 “OK” 버튼을 클릭하면 Catalog가 Restore 된다. 
 
 
 
 
 
 
 
 
 
 
 

 Options 

a. Keep Assigned Part/Decal: Mapping이 되지 않은 Value의 Part만 Restore 한다. 

b. Replace All: Mapping 여부와 상관없이 모든 Value의 Part를 Restore 한다.  

c. Ask Before Part/Decal Change: Replace All Option시 Value의 Part가 이미 존재할 경우 변경 여부 선택할 
수 있는 창이 생성된다. 
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Save Catalog 
cowork에서 생성 또는 변경한 Mapping정보를 Catalog(*.cwk) 파일로 저장하는 기능이다. 

cowork > File > Save 또는 Save 아이콘 을 실행하면 현재 Layout에 열려있는 pcb파일이 있는 디렉토리에 
pcb파일이름.cwk 파일로 저장된다. 

Note: cowork을 다시 실행할 때 해당 pcb 디자인 하단에 저장된 cwk 파일을 참조한다. 
 

Design Rule Check (DRC) 
OrCAD Netlist 또는 Catalog 오류를 검사하는 기능이다. 

Note: DRC를 통해 발견된 오류/경고 메시지는 중요한 내용이므로 반드시 확인해야 한다. 

1 cowork > Tools > Design Rule Check 또는 DRC 아이콘 을 실행하면 오류검사 후 결과가 출력된다. 
2 오류/경고 메시지 

 PADS Layout의 Decal Editor가 실행중입니다. Decal Editor를 종료한 후 다시 시도하십시오. 

PADS Layout의 Decal Editor가 실행중인 경우 알림 메시지를 출력되고 검사가 중지된다. 
이 경우 실행중인 Decal Editor를 종료하고 다시 시도한다. 

 

 Net에 사용할 수 없는 문자가 포함되어 X??로 이름이 변경되었습니다. 

OrCAD에 사용한 Net명중 PADS Layout에서 사용할 수 없는 문자가 포함된 경우 Net명이 X+임의숫자로 
변경된다. 이 경우 Net명 변경 정보가 검사결과 레포트에 Warning으로 표시되며 변경 정보는 OrCAD에서 
Netlist 생성시 발생한 Session Log 파일을 통해 확인 할 수 있다. 

 

 Port/Offpag를 사용하지 않아 다른 페이지와 연결되지 못한 Net가 발견되었습니다. 

OrCAD는 offpag나 port를 사용하지 않고 Net명만 기입하여 회로를 작성한 경우 다른 sheet와 연결 되지 
않는다. 이 경우 Net명으로만 기입된 Net가 검사결과 레포트에 Warning으로 표시된다. 

 
 
 
 
 
 
 
 
 
 

Note: Net명으로 기입된 Net가 다른 sheet와 연결 되지 않아도 되는지 확인해야 한다. 
 

 One Pin Nets이 발견되었습니다. 

One pin nets이 발견되었을 때 One pin list가 검사결과 레포트에 Warning으로 표시된다. 
 

 Value에 Part가 설정되지 않았습니다. 

Catalog에 있는 Value에 Part가 Mapping되지 않았을 때 Mapping 되지 않은 리스트가 검사결과 레포트에 
Error로 표시된다. 

Note: Mapping 되지 않은 Value를 확인 하여 Part를 Mapping해야 ECO가 가능하다. 
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 OrCAD 보다 PADS Part의 Pin수가 많은 부품이 발견되었습니다. 

PADS Part의 Pin 수가 OrCAD Part의 Pin수보다 많은 경우 검사결과 레포트에 Warning으로 표시된다. 
 
 
 
 
 
 
 
 
 
 
 
 
 

PADS 
14 Pin 
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OrCAD 
8 Pin 

 OrCAD 보다 PADS Part의 Pin수가 작은 부품이 발견되었습니다. 

PADS Part의 Pin 수가 OrCAD Part의 Pin수보다 작은 경우 검사결과 레포트에 Error로 표시된다. 
 
 
 
 
 
 
 
 
 
 
 

Note: PADS Part의 Pin 수가 작은 경우 확인하여 정확한 Part를 Mapping해야 ECO가 가능하다. 
 

U3
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OrCAD 
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PADS 
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 Part를 PADS Library에서 찾을 수 없습니다. 

Catalog에 사용한 PADS Part를 PADS Library 또는 현재 Design에서 찾을 수 없는 경우 검사결과 레포트에 
Error로 표시된다. 

Note: Catalog에 사용한 Part는 PADS Library 또는 현재 Design에 존재 해야 ECO가 가능하다.  
 

 PADS Library의 Part에 할당된 Decal을 찾을 수 없습니다. 

Catalog에 사용한 PADS Part에 연결된 Decal을 찾을 수 없거나 Decal에 오류가 있을 때 검사결과 레포트에 
Error로 표시된다. 

Note: Catalog에 사용한 PADS Part에 연결된 Decal을 확인하여 오류를 해결해야 ECO가 가능하다.  
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ECO 
Import한 OrCAD Data와 Mapping한 Catalog를 이용하여 PADS Layout의 Design 데이터를 생성하거나 업데이트하는 
기능이다. 

Important: 기존 프로그램의 ECO는 에러가 발생할 경우 무시하고 업데이트된 후 로그파일이  
            생성되었지만 cowork 프로그램은 에러가 발생하면 업데이트되지 않고 ECO가 중지된다. 

1 cowork > Tools > ECO to .pcb 또는 ECO 아이콘 을 실행한다. 
2 DRC 검사 후 에러가 없으면 OrCAD Data와 Catalog를 기준으로 PADS Layout에 데이터를 생성하거나 업데이트 

한 후 결과가 출력된다. 
Note: 자세한 변경정보는 cowork > Window > Session Log를 이용하여 확인 할 수 있다. 

 부품추가: 추가된 부품의 총 개수. 

 부품삭제: 삭제된 부품의 총 개수. 

 Part Type 변경: Decal 또는 Part Type이 변경된 부품의 총 개수. 

 REF(U?) 변경: Reference가 변경된 부품의 총 개수. 

 VALUE 변경: Value가 변경된 부품의 총 개수. 

 NET NAME 추가/변경: 추가되거나 변경된 Net 이름의 총 개수. 

 NET Connection 삭제: 삭제된 Net Connection 총 개수. 

 NET Connection 추가: 추가된 Net Connection 총 개수. 

 MECHANICAL PART($?): Layout에서 임의 추가된 부품의 총 개수. 

3 오류/경고 메시지 

 ECO 업데이트 중 오류가 발견되어 작업이 취소되었습니다. 

 DRC 기능으로 발견되지 못한 에러가 발생했을 때 로그파일이 생성되고 ECO가 중지된다. 
 PADS Layout에서 생성한 ECO 로그파일을 확인하여 에러를 해결하고 다시 시도하면 된다. 
 에러내용을 알 수 없을 때 아래 연락처로 연락하면 기술지원을 받을 수 있다. 
 (E-mail: support@intercad.co.kr / Tel: 031-786-0123)  

Note: 기타는 매뉴얼 Design Rule Check의 오류/경고 메시지(14/15쪽)와 동일.  

 

Layout 에서 사용자가 추가한 부품(고정홀, Vision Mark, Test Point…)의 ECO 제외 
PADS Layout에서 사용자가 필요에 의하여 임의로 Part를 추가한 경우 ECO에서 제외할 수 있는 기능이다. 

 PADS Layout에서 임의로 추가한 부품 Reference 앞에 $를 추가하면 해당 Part 및 Part와 연결된 Net는 ECO시 
Mechanical Part로 인식하여 삭제되지 않는다. 

 
 
 
 
 
 
 
 
 
 
 
 
 

Reference앞에 

$ 추가 
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Back Annotate 
Layout 부품정보를 OrCAD 회로도에 업데이트할 수 있는 swp 파일을 생성하는 기능으로 Layout의 Reference 변경, 
Geometry, Location 정보를 OrCAD Part의 Property에 업데이트 할 수 있다. 

 

Opt ons:  i
 Include Part Types 

a. PCB Package: OrCAD Property의 PCB 
Package항목에 Decal 정보가 입력된다. 

b. PCB Footprint: OrCAD Property의 PCB  
Footprint항목에 Decal 정보가 입력된다. 

1 CoWork > File > Back Annotate를 실행하면 Option창이 나타난다. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

2 OK를 실행하면 아래와 같이 Report창이 출력된다. 
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3 OrCAD 회로도를 열고 Tools > Back Annotate를 실행한다. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

6 

4 
5

4 Update Instances Mode를 선택한다. 
5 Browse아이콘을 이용하여 Layout에서 생성한 swp파일을 선택하여 Back Annotate를 실행한다. 

6 OrCAD 데이터를 저장한다. 

 

Important:  Back Annotate 명령을 실행 한 후 회로도 오픈이나 변경을 하기 전에 반드시 데이터 저장을  
             해야 한다, 만약 저장하지 않고 회로도를 열거나 변경할 경우 Back Annotate된 정보 일부가  
             변경되지 않아 문제를 발생 시킬 수 있다. 

 

7 Merge를 완료한 후 Property값에 PCB Package, Part Location, REF Location항목이 생성된 것을 확인 할 수 있다. 
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Back Annotate 을 이용한 동일한 Block 배치 
1 Layout에서 한 개의 Block을 배치한 후 Cowork > file > Back Annotate를 이용하여 swp파일을 생성한다. 

2 OrCAD 회로도를 오픈하여 Layout에서 생성한 swp파일을 이용하여 Back Annotate 한 후 저장한다. 

3 OrCAD 회로도에서 같은 Block이 여러 개 있는 Sheet에서 아래와 같이 배치된 Part만 선택하여 Copy한 후 
Paste한다. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

동일 Block일 때 Part를 
선택한 후 Copy하여 
Paste한다. 

4 OrCAD에서 Netlist를 출력한다. 

5 Cowork > Open을 하여 OrCAD에서 출력한 Netlist를 Import한 후 ECO를 진행하게 되면, Layout창에 OrCAD에서 
Copy한 부품이 불러진다. 

Opt ons:  i
 Selected Components: 

선택한 부품만 Restore하겠다. 
 All Components: 

전체의 부품을 Restore하겠다. 
 Keep Glued Components: 

Fix한 부품은 Restore 하지 않는다. 

6 Cowork > Tools > Reuse Placement를 실행하면 Option창이 나타난다. 
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7 Start를 실행하면 아래와 같이 회로도에 Merge된 Location으로 Component가 Restore된다. 
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Team Placement 
CoWork의 Back Annotate기능을 응용한 기능으로, Back Annotate를 실행하면 Layout의 Reference, Part의 정보들이 
OrCAD Property로 입력됨으로써 하나의 Layout파일로 Multi User가 작업완료 후 하나의 파일로 통합할 수 있는 기능

이다. 
1 OrCAD DSN의 파일, PADS의 Layout file 원본을 제외한 각각 복사본을 생성한다. 
2 복사본 Layout파일에서 배치작업을 하고 CoWork Program을 실행하고 Pull Down Menu에 File > Back Annotate를 

실행한다. 
3 OrCAD에서 해당 모델을 Open한 후, Pull Down Menu에 Tools > Back Annotate를 실행하여 SWP파일을 이용하여 

Merge하고 원본 파일이 있는 PC로 이동한다. (DSN, Layout) 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

원본 

복사본 
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4 원본 Layout파일을 Open한 후 작업한 배치 Part를 선택 > Menu key > Properties를 실행하여 아래의 그림과 같이 
Glued에 Check를 한 후 OK를 실행한다. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Options:  
 Parts: Part를 Reuse 한다. 
 Ref.Des: Reference의 Location을 Reuse 한다. 

5 Cowork Program을 실행하여 OrCAD의 복사본 DSN파일을 Open한 후 CoWork > Tools > Reuse Placement를 
실행한다. Option창이 나타나는데 위에서 Glued한 Part를 제외한 모든 Part와 Reference를 Reuse하겠다 라고 
설정한 후 Start를 실행한다. 
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6 Reuse를 실행한 결과 원본파일에서 Glued Part를 제외한 나머지 Part는 복사본의 배치된 Part와 Reference가 
통합되는걸 아래 그림을 통해 확인할 수 있다. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Layout 

배치작업 

CoWork Back Annotate 실행 & 

OrCAD에서 SWP File Merge 실행 

통합할 PC로 File 이동(DSN, Layout) 

a. 원본 Layout에서 배치한 Parts를 Glued 시킨다. 

b. 이동한 DSN파일을 CoWork Program을 통해 Open

한다. 

c. CoWork Program에 Tools > Reuse Placement실행 

 

 

Layout  

배치작업 

 

[작업이해도] 

 

 

DSN, Layout 

원본 

원본 DSN, Layout 

파일을 다른 이름으

로 저장 또는 복사 

DSN, Layout 

복사본 
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CoWork Alphabet Pin Number Check Option 
OrCAD회로도에서 Symbol의 Pin number를 문자로 사용하였을 때 CoWork Program에서 해당 문자의 검사 여부를 설

정하는 기능이다. 
1 PADS Layout File을 Open한다. 

Options:  
 Errors: DSN파일을 Open할 때 Pin Number가 

문자로 되어 있을 경우 Error Message를 
출력하며 중지된다. . 

 Warnings: DSN파일을 Open할 때 Pin 
Number가 문자로 되어 있을 경우 Warning 
Message를 출력하고 다음 단계를 실행한다. 

 No Checking: DSN파일을 Open할 때 Pin No를 
검사하지 않는다. 

2 CoWork Program을 실행하여 Pull Down Menu에 Option > Preferences를 실행하여 Option을 설정한다. 
Option설정을 완료한 후 OK버튼을 실행한다. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

3 CoWork에서 DSN파일을 선택하여 Open할 때 Alphabet Pin Number 발견 시 Preference의 옵션에 따라 아래와 
같이 동작된다. 

 Check Alphabet Pin Number값을 Errors로 Check 한 경우 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 Check Alphabet Pin Number값을 Warnings로 Check 한 경우 
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Find Function 
CoWork 프로그램에 Mapping되어 있는 Catalog List에서 Part, Value, Reference등을 찾을 수 있는 기능이다. 
1 PADS Layout File을 실행한다. 
2 CoWork Program을 실행한 후 Pull Down Menu에 File > Open 또는 Open아이콘을 이용하여 DSN파일을 

Open한다. 
3 CoWork을 선택한 후 Pull Down Menu에 Edit > Find 또는 CTRL+F 키를 이용하여 Find 기능을 실행한다. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

4 Find창의 Option에 찾고자 하는 범위를 선택한 후 원하는 값을 입력하여 OK를 실행한다. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Op ons:  ti
 Part: Decal Name을 입력한다. 
 Value: OrCAD에 Symbol Value값을 입력한다. 
 Reference: Reference값을 입력한다. (*)는 사용할 수 없다. 
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Cross Probing 
OrCAD 회로도에서 선택한 부품 또는 Net를 Layout에서 선택하거나 이동할 수 있는 기능이다. 

1 Union의 Cross Probing을 기능을 설정한다 

마우스를 union 트레이 아이콘에 위치한 후 마우스 오른쪽 버튼을 클릭하여 Select 하단의 옵션을 설정하면 된다 

 

 

 

 

 

 

 Cross Probing:  Cross Probing 모드를 On/Off 할 수 있다. 

 Move Selected: 부품 선택된 후 Layout으로 화면 이동시 Move 모드로 동작한다.  

2 Layout과 OrCAD 회로도를 실행시킨다. 

3 OrCAD 회로도에서 부품 또는 Net를 클릭하면 Layout의 부품 또는 Net가 선택된다. 

 심볼(Part/ Port/ Offpag/GND/VCC) 및 NET 선택하는 방법 

 OrCAD 회로도에서 심볼 및 NET를 선택하면 해당 심볼이 Layout에서 선택된다. 
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 여러 개의 부품/Nets를 한번에 선택하는 방법 
a. 회로도에서 Cross Probing할 부품/Nets를 선택한다. 
b. 회로도에서 Stroke 명령어 (→) 또는 마우스 오른쪽 버튼을 이용하여 Edit Properties를 실행한다. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

b 

c. Property Editor에서 Reference 글자를 클릭하여 전체 Reference를 선택한다. 
    Note: 부품이 아니고 Net인 경우에는 Name 글자를 클릭하여 전체 Nets를 선택한다. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Note:  Reference Column의 위치는 Filter by를 “Orcad-Capture”로 변경하여 앞에 표기 되도록 
설정할 수 있다. 

 
 
 
 
 
 
 
 
 
 
 
 
 

c 
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d. Property Editor 창에서 Reference를 선택한 후 키보드 Tab키를 입력하면 Property Editor 창이 종료되면서 
선택된 부품이 Layout에 선택된다. 
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프로그램 사용시 주의 사항 
1 TR, FET, Diode, ECAP, TCAP 부품의 극성 및 Pin Number 확인 

OrCAD에서 기본으로 제공하는 라이브러리 중 TR, Diode, FET는 Pin Number가 알파벳(Anode, Cathode, Emitter, 
Base…)으로 표기되어 있다, 알파벳으로 된 Pin Number는 회로도에서 숫자로 변경해야 한다. 

ECAP, TCAP, Diode등 극성이 있는 부품 및 3단자 부품은 Geometry에 Pin(극성 표기 Silk가 있는 방향) 위치와 
회로도의 Pin이 일치하는지 확인해야 한다. 

2 Gate Symbol의 Power 확인 (And, Not, Or…. Gate) 
OrCAD에서 Power가 숨겨진 부품(Gate….)을 사용할 경우 실제 연결 되야 하는 Power와 이름이 달라 연결되지 
않을 수 있다. 
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